The Jack's Small Engines Forum - Join Our Online Community
Reply to post

Flat Surface Attachment for Pressure Washers

Author
humblerb
Junior Member
  • Total Posts : 18
  • Scores: 0
  • Reward points: 0
  • Joined: 2020/06/17 20:56:07
  • Status: offline
2020/07/27 18:28:23 (permalink)
0

Flat Surface Attachment for Pressure Washers

I had a Briggs Flat Surface Cleaner for years and was awesome.
It finally broke the plastic housing, so I had to replace.
Searching the internet to see which cleaners were rated best, I saw reviews where almost all different brands were having trouble not turning. They shoot water through them, but they will not spin and clean.
I bought a Briggs and it would not spin.
Took it back and ordered a Simpson and it will not spin. Called Simpson customer service and they are sending me another one.
I did everything that people suggested on the internet - lubricate the connection, remove the nozzles and clean out, etc.
I find it hard to believe that almost all brands have the same issue and find it hard to believe that the solution is to keep replacing until I find one that works.
Has anyone else had this issue and found a long-lasting solution?
I've got about 2 hours of cleaning with the flat surface attachment. No way I can spend two weeks cleaning with just a nozzle.

2 Replies Related Threads

    humblerb
    Junior Member
    • Total Posts : 18
    • Scores: 0
    • Reward points: 0
    • Joined: 2020/06/17 20:56:07
    • Status: offline
    Re: Flat Surface Attachment for Pressure Washers 2020/07/31 17:26:21 (permalink)
    0
    Received my second Simpson last night.
    Used it for an hour or so today and it works fine.
    Will see if it continues to work next week.
    Still curious why so many of these don't spin. 
    You can freely spin them with your hand.
    Water cones out, but they won't spin with water pressure.
    I even took them apart and greased them and cleaned out the tubes.
    humblerb
    Junior Member
    • Total Posts : 18
    • Scores: 0
    • Reward points: 0
    • Joined: 2020/06/17 20:56:07
    • Status: offline
    Re: Flat Surface Attachment for Pressure Washers 2020/08/28 09:02:58 (permalink)
    0
    Used the new Simpson again yesterday. Worked fine for an hour or so.
    Took a break for an hour or so to move patio furniture around.
    Started using again and not enough power to spin fast enough to clean.
    Frustrated, I took everything apart and cleaned and lubricated.
    It worked afterward. Doesn't make sense that the manufacturers put these out without lubrication, but that is what seems to make them work again. Even if fixing them was acceptable, I'm afraid that repeated removal of the jets will eventually wear the threads out.
    I had one for years that I had no problems with and never had to "fix" it.
    Frustrating.
    Jump to:
    Copyright © 1994 - 2016 Jacks Small Engine & Generator Service, LLC