The Jack's Small Engines Forum - Join Our Online Community
Reply to post

Hot!Wire on Armature/Magneto

Author
Bogart
New Member
  • Total Posts : 3
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/10/18 10:31:38
  • Status: offline
2016/10/18 10:37:48 (permalink)
0

Wire on Armature/Magneto

On my 14.5HP  BS series 2800 there is a small grey wire connected to the Armature/Magneto. If I disconnect this the engine starts and runs fine if I connect it will only turn over not start. Is this something to do with a stop switch? If so can anyone tell me how to fix this problem?
 
Regards

5 Replies Related Threads

    Mikel1
    Moderator
    • Total Posts : 506
    • Scores: 31
    • Reward points: 1
    • Joined: 2016/04/14 18:48:53
    • Location: Georgia
    • Status: offline
    Re: Wire on Armature/Magneto 2016/10/18 11:40:42 (permalink)
    0
    It is part of the safety system(circuit), it grounds out the coil killing spark. When you disconnect the wire it can not ground coil out.
    A wiring diagram would help you but I have no idea what your working on.
    Bogart
    New Member
    • Total Posts : 3
    • Scores: 0
    • Reward points: 0
    • Joined: 2016/10/18 10:31:38
    • Status: offline
    Re: Wire on Armature/Magneto 2016/10/18 13:24:46 (permalink)
    0
    I would love a wiring diagram Am having to make one up as I go along. The unit is a Westwood ride on mower. I have taken the ignition switch out and that seems ok so somewhere else this wire is getting grounded. Will have to wait until the morning as is dark now
     
    Thanks
    Mikel1
    Moderator
    • Total Posts : 506
    • Scores: 31
    • Reward points: 1
    • Joined: 2016/04/14 18:48:53
    • Location: Georgia
    • Status: offline
    Re: Wire on Armature/Magneto 2016/10/19 13:34:59 (permalink)
    0
    Didn't realize this was a UK model.
    I would check the wiring/connectors and ohm wires for any breaks then inspect the safety switches . Since it cranks you are getting 12V to the starter solenoid.
    Bogart
    New Member
    • Total Posts : 3
    • Scores: 0
    • Reward points: 0
    • Joined: 2016/10/18 10:31:38
    • Status: offline
    Re: Wire on Armature/Magneto 2016/10/20 07:38:21 (permalink)
    0
    Have now got a wiring diagram. Problem is when switch G is in on position there is some connection between the kill switch and the pcb sufficiently to let it not start. If I remove the wire between the switch G and the pcb it works fine. Amtrying to find what the input or output on PCB connector 14 actually does. Anyway at least I have got it running. Sorry but the diagram is at a poor resolution.
    Mikel1
    Moderator
    • Total Posts : 506
    • Scores: 31
    • Reward points: 1
    • Joined: 2016/04/14 18:48:53
    • Location: Georgia
    • Status: offline
    Re: Wire on Armature/Magneto 2016/10/22 21:15:09 (permalink)
    0
    Yep looking at the diagram I believe you are correct. Hopefully you will get it figured out.
    Jump to:
    Copyright © 1994 - 2016 Jacks Small Engine & Generator Service, LLC