The Jack's Small Engines Forum - Join Our Online Community
Reply to post

Hot!20 HP Onan issues

Author
briannelson
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/11/29 19:51:01
  • Status: offline
2016/11/29 22:56:30 (permalink)
0

20 HP Onan issues

I have a 420 Steiner with a 20 HP Onan.  It runs fine until you load the engine, like when you engage the PTO on the snow blower and try to blow snow. The engine starts missing and backfires thru the intake. I try and choke it but only gets worse. Have had a good mechanic look at it twice, he tinkers with the carb and it runs OK for 30 min or so then back to no power and backfiring. The engine does have 1900 hours on it? maybe its wore out? Any ideas?

2 Replies Related Threads

    Roy
    Moderator
    • Total Posts : 226
    • Scores: 2
    • Reward points: 1
    • Joined: 2016/07/27 22:51:23
    • Location: British Columbia
    • Status: offline
    Re: 20 HP Onan issues 2016/11/30 19:51:58 (permalink)
    0
    1900 hours is nothing for that engine, it's just nicely broken in. I would be looking for cracks in the spark plug wires allowing arcs to ground. The coil itself could also be leaking.
    Mikel1
    Moderator
    • Total Posts : 759
    • Scores: 39
    • Reward points: 1
    • Joined: 2016/04/14 18:48:53
    • Location: Georgia
    • Status: offline
    Re: 20 HP Onan issues 2016/12/02 09:45:37 (permalink)
    0
    Have you changed spark plugs? If you have then check spark plugs condition.
    When you have a load it requires more fuel, so may be fuel related. What exactly do you mean by tinker with carb?
    Jump to:
    Copyright © 1994 - 2016 Jacks Small Engine & Generator Service, LLC