The Jack's Small Engines Forum - Join Our Online Community
Reply to post

Hot!Problem starting Snapper 33" Hi-vac with 17 hp Briggs & Stratton Intek engine

Author
Prodigal Utopian
New Member
  • Total Posts : 3
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/02/26 22:01:25
  • Status: offline
2016/02/26 22:15:41 (permalink)
0

Problem starting Snapper 33" Hi-vac with 17 hp Briggs & Stratton Intek engine

New oil, oil filter, fuel, fuel filter, air filters, spark plug, solenoid......Mower is in excellent condition.....Went to start it this afternoon and could not get it to fire up. Tried a shot of starting fluid and it fires for just a few seconds but won't stay running. Any help with this will be greatly appreciated. Anyone have any ideas as to how to get this rascal running?

3 Replies Related Threads

    TheLawnmowerMan
    Junior Member
    • Total Posts : 20
    • Scores: 0
    • Reward points: 0
    • Joined: 2016/03/17 18:30:27
    • Status: offline
    Re: Problem starting Snapper 33" Hi-vac with 17 hp Briggs & Stratton Intek engine 2016/03/17 19:11:09 (permalink)
    0
    My swag would be that since it runs when you introduce fuel (starter fluid) directly into the carb there is a carb related problem.  Check that the fuel is fresh and getting to the carb.  If thats good, you will need to rebuild the carb or replace it.
    dougf
    New Member
    • Total Posts : 1
    • Scores: 0
    • Reward points: 0
    • Joined: 2016/08/27 14:55:20
    • Status: offline
    Re: Problem starting Snapper 33" Hi-vac with 17 hp Briggs & Stratton Intek engine 2016/08/27 15:29:25 (permalink)
    0
    If it runs with gas or starter fluid inserted manually, the spark system is working and engine is not frozen.  Carb is the issue per TheLawnmowerMan.
     
    I have had good luck just removing carb and using solvent (B12 or Gumout) to clean up the varnish and dirt in the bowl.  Clean the exterior with a brush and gasoline or mineral spirits.  
     
    Spray solvent up the tube from the bowl to the venturi too.  It has to be clean for gas to make it into the air flow.
     
    Reassemble and give it a try.
    post edited by dougf - 2016/08/27 15:31:04
    Pathassett
    Starting Member
    • Total Posts : 12
    • Scores: 0
    • Reward points: 0
    • Joined: 2016/08/28 21:00:08
    • Status: offline
    Re: Problem starting Snapper 33" Hi-vac with 17 hp Briggs & Stratton Intek engine 2016/08/29 01:44:33 (permalink)
    0
    Sounds like the float valve is stuck closed. Take off the float bowl and clean the bowl and float valve. Make sure the float valve is moving. Put it all back together. It should work after that. If not then the cleaning and rebuild as suggested by Doug would be your only course.
    post edited by Pathassett - 2016/08/29 10:57:08
    Jump to:
    Copyright © 1994 - 2016 Jacks Small Engine & Generator Service, LLC