The Jack's Small Engines Forum - Join Our Online Community
Reply to post

Hot!Cub Cadet 1333 SWE snowblower

Author
GoSioux
New Member
  • Total Posts : 3
  • Scores: 0
  • Reward points: 0
  • Joined: 2019/02/03 17:12:54
  • Status: offline
2019/02/03 17:21:30 (permalink)
0

Cub Cadet 1333 SWE snowblower

I just bought a used Cub Cadet 1333 SWE. It starts fine, but when I engage the auger and start blowing snow it cuts out and loses power..., almost like it is going to kill. I drained the fuel, added premium fuel (with some seafoam) and replaced the spark plug. It does not seem to have helped. Also, I always have to keep the engine at about 1/2 choke or it will die. Any thoughts? Thanks!

3 Replies Related Threads

    GoSioux
    New Member
    • Total Posts : 3
    • Scores: 0
    • Reward points: 0
    • Joined: 2019/02/03 17:12:54
    • Status: offline
    Re: Cub Cadet 1333 SWE snowblower 2019/02/03 17:22:21 (permalink)
    0
    Let me add it does a bit of sputtering while idling.
    Roy
    Moderator
    • Total Posts : 824
    • Scores: 13
    • Reward points: 1
    • Joined: 2016/07/27 22:51:23
    • Location: British Columbia
    • Status: offline
    Re: Cub Cadet 1333 SWE snowblower 2019/02/03 22:09:46 (permalink)
    0
    How long was it sitting before you bought it? Sounds like the carburetor needs cleaning. Shut the fuel off and remove the bowl, you may find a bit of grunge in it.
    GoSioux
    New Member
    • Total Posts : 3
    • Scores: 0
    • Reward points: 0
    • Joined: 2019/02/03 17:12:54
    • Status: offline
    Re: Cub Cadet 1333 SWE snowblower 2019/02/04 09:11:44 (permalink)
    0
    I think it has been sitting for a year or two. I’m not sure.
    Jump to:
    Copyright © 1994 - 2016 Jacks Small Engine & Generator Service, LLC